Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
World map blank.
01-05-2020, 01:09 AM,
World map blank.
Hello Jordi,

My SWL world map has gone totally blank. I'm sure I had this issue before - but trawled through the threads and could not find any reference to the error. I'm sure you did give me advice on how to fix this previously and if so I apologise for raising it again.

It happened when I came to add a new logbook entry - SWL froze and I had to manually shut it down. Then when I re-opened it - the world map was blank. Restarted the PC and fired SWL up again but no change.

There seems to be no 'settings for active window' either when the world map is selected ??

Any tips/advice appreciated.

Thank you.

73 de Richard G4UGB
01-05-2020, 02:06 AM,
RE: World map blank.
Hello Richard,

Try to enter the map setup then load the environment file SWISSLOG.ENV from the MAPS folder. If not working, do you have a backup copy of the whole Swisslog folder? Probably the Environment map file is corrupted. If you keep a copy of the whole Swisslog folder simply restore the SWISSLOG.ENV from/to the MAPS folder.

If you don't have a copy and still having issues with the worlp map, if you have Swisslog installed in C:\Swisslog, delete the SWISSLOG.ENV file from the MAPS folder then reinstall Swisslog. The installer will install again the default file.

If you still on trouble, please send me screenshots to my e-mail address:

Maybe we should arrange a remote session via Teamviewer if you are not able to solve this issue.

Best 73
Jordi, EA3GCV
Current developer of Swisslog
01-05-2020, 02:08 PM, (This post was last modified: 01-05-2020, 02:24 PM by G4UGB.)
RE: World map blank.
Hello Jordi,

Many thanks - deleting the map file and reinstalling SWL cured it - the map is back in all its glory !!!

However - sad to relate - I seem to have an additional issue. It happened at the same time as SWL crashed and I lost the map. It was not communicating with the transceiver in that the frequency and mode stopped displaying at the top of the SWL screen. I thought the re-install would sort that out too but it hasn't.

I use an Icom 7610 with the CAT address 98h. When I put this into the transceiver interface - SWL does not accept it initially E0 was in the address window - an error window pops up and says '$98h is not a valid integer value' and then it seems to want to default to E0. However I got it to accept 98h but now the mode and frequency display will not start automatically - and will only change within SWL when I hit the 'start' button in the Transceiver Interface panel.

This worked perfectly up until this crash. I have no idea what has happened.

Any thoughts ?? The COM port used for SWL is from a virtual COM port on my Microham Microkeyer III and like I say - it all worked perfectly fine before this crash the other day so I am puzzled as to what has happened.

** Quick Edit - I note that if I shift click on a spot frequency in the DX Messages window - the SWL frequency display and mode changes to match and the transceiver changes frequency to the spot frequency. But if I rotate the dial on the transceiver or change mode - the SWL frequency and mode remain as they were and don't change - until I go into the Transceiver Interface and hit the start button again.


01-05-2020, 02:53 PM,
RE: World map blank.
Hello Jordi,

Issue resolved. For some reason - and I know not why - the 'CIV Transceive' setting within the transceiver CAT control options had been turned off. Turned it on and now all is well and SWL frequency and mode displays respond correctly with CIV address at 98.


Thank you,

Richard G4UGB

Forum Jump:

Users browsing this thread: 1 Guest(s)