Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Access Violation LOTW Configuration
19-07-2017, 07:52 PM, (This post was last modified: 19-07-2017, 07:54 PM by hb9dhg.)
Access Violation LOTW Configuration
Ciao Jordi,

since several weeks (I honestly do not remember the first time I seen this error)
I got a pop up error (Access Violation) when I want to start the LOTW Synchronisation.
I was able to identify that the username/password fields were empty (have a look at the screen shots)
I also noted that if I enter the corresponding username/password, and then I run the LOTW synchronisation, everything is working well
but as soon as I close the window and then I restart it, i have the same error.
Everything is running as administration and I do not know where the problem is.
Do you have any suggestion ?

Thank you!
HB9DHG Fulvio

Attached Files Thumbnail(s)
20-07-2017, 11:30 AM,
RE: Access Violation LOTW Configuration
Hi Fulvio:

The fields LoTW Web User and LoTW Web Password are used ONLY to access the LotW website when pressing the "Open LOTW web page" located in the LotW synch function, not to perform the LotW synchronisation.

This error is normally displayed when the certificate password set in Swisslog doesn't match with the password certificate defined in TQSL (or you have set a password certificate in and you have not set it in Swisslog).

Please review your TQSL certificate settings and your settings in the Configuration tab in the LotW synch function.

Best 73
Jordi, EA3GCV
Current developer of Swisslog
24-07-2017, 02:55 PM,
RE: Access Violation LOTW Configuration
Hi Jordi,

sorry for the late reply. That make sense to me !
I will check this in the next days and I will keep you posted.
Thank you for your guidance

73 de HB9DHG Fulvio
25-07-2017, 01:20 AM,
RE: Access Violation LOTW Configuration
Hi Fulvio, 

Just let you know that current version has a small bug in the LoTW configuration (it will be corrected in 5.97).  If user has set a certicate password in the Swisslog LoTW configuration and later you delete the password in your certicate (i. E.  when renewing the certificate) you won't be able to set a blank password in the certicate password configuration of Swisslog.  The only way to do this is to edit the file Swl_lotw.ini located in the LoTW and delete the password besides the certificate name. 

I just want to inform you so that you are aware on this. 

Best 73
Jordi, EA3GCV
Current developer of Swisslog
25-07-2017, 11:44 PM, (This post was last modified: 25-07-2017, 11:46 PM by hb9dhg.)
RE: Access Violation LOTW Configuration
Hi Jordy,

this is what fixed my issue.
It was not a password error (I have the same password for all my certificates). I simply removed some unwanted calls from the swl_lotw.ini file and everything is running back smoothly as before.
Thanks for fixing this in the next release.
Looking forward to test it.

Keep up your excellent deployment!

Fulvio HB9DHG

Forum Jump:

Users browsing this thread: 1 Guest(s)