Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TQSL signing problem! (Swisslog)
17-02-2014, 07:15 PM,
#1
TQSL signing problem! (Swisslog)
Hi,

I have tried to export an ADIF file from Swisslog, and then sign it with TQSL and upload it to LOTW.
I manage to export the file from Swisslog, but when I try to sign it with TQSL, an error message comes up.

Here is a picture of the error: http://gyazo.com/103219b942c8c65a4fe4266bfa5aade6
Then it counts up to my total of 24000 +
http://gyazo.com/1a3f8aea4571c0aec2e57a200350ae2b

Me and my son have tried this over a period of time, and we have almost given up. Today we tried to export all my contacts from Swisslog to N1MM and tried to sign an ADIF file from there. Same problem.. But error on line 9 instead of 12 as in swisslog. http://gyazo.com/fdc14491b2f6c28788fb3a09acafdd63


And after some thinking, we have found out that all contacts in Swisslog ends in 1899!
So we guess we have found the "problem"? http://gyazo.com/ba928a7369dfd8a6688f6e1fd347260b 30.12.1899 as an end date is outside the certificate period.

This contact LA1U we just saved as the date of today "14.02.2014" came up as "30.12.1899". Wtf is this? Can we do something about it? We really need all my contacts online on LOTW Smile

Thank you so much.
LA1MFA/Kjell
Reply
18-02-2014, 09:18 AM, (This post was last modified: 18-02-2014, 09:20 AM by EA3GCV.)
#2
RE: TQSL signing problem! (Swisslog)
Dear KJell,

The problem is that you are making all the syncronisation processes manually and Swisslog implements a fully automated support to sync with the LoTW.

Please find attached the LotW documentation to setup LotW in Swisslog. There are 2 documents attached:

- LoTW Preparation
- LotW Support

The LoTw Preparation basically explains the first steps before setting up LotW with Swisslog. You have to install the last version of Trusted QSL from the ARRL LotW web page, install certificates and VERY important you have to add Stations in TQSL as many as QTH you have in Swisslog. Later you have to match every QTH in Swisslog with a LoTW station. This document explain these basic and needed steps.

The Lotw Support documents explain the function itself. There are 2 modes: manual and automatic. Take a quick view to the manual mode to understand all the steps but use the automatic mode.

At the end of the syncronization there is "small" bug that appeared since the release of TQSL 2.0. When Swisslog prompts you to assign a field to APP_LoTW_MODEGROUP, select the Swisslog field C_NOTE (or L_NOTE if you wish) from the right list and assign it with the left arrow button. This is a new field that TQSL has implemented but as you know Walter is not able to develop Swisslog anymore and this "bug" must be solved manually. It's not important at all for the syncronisation but you have to assign it to any of these fields to end the process properly.

Last but not least important, if you have Windows Vista or upper, you have to install and run ALL programs (TQSL, Swisslog and I suggest you ALL window programs) with administrator rights. This is done by right click on the file and select "Run as a administrator". I also highly recommend you to disable UAC (User Account Control). Google "Disable UAC" and add your operating system to know how to do it. You can set to run as a administrator in the programs you have already installed by right click in the program icon, select Properties, Compatibility tab, and check the box "Run as a admnistrator".

I hope all these documentation and explanations will make you understand everything. If you read all carefully you shouldn't have any problem.

Best 73


Attached Files
.pdf   LoTW Preparation.pdf (Size: 147,93 KB / Downloads: 16)
.pdf   LoTW Support.pdf (Size: 134,88 KB / Downloads: 13)
Jordi, EA3GCV
Current developer of Swisslog
Reply
18-02-2014, 07:54 PM,
#3
RE: TQSL signing problem! (Swisslog)
(18-02-2014, 09:18 AM)ea3gcv Wrote: Dear KJell,
Best 73

Hey!

Thank you for answering me fast. So I see.. the problem is that we have done it manually, okey so let me try to do it automatically.

I had the LOTW allready setup in Swisslog, but I read the pdf's and went over the settings agian. Everything looked okey.
I forgot to mention that we have tried to do this process erlier in Swisslog, and it only "finds" 3011 qso's.
http://gyazo.com/73cdaed755e859b89c5b993bdd891e2c

When I press export qso's / start sync it counts up 90 qso's. http://gyazo.com/05990ea6451667179efab5c725e2578c
then it jumps from export qso's to update status.
http://gyazo.com/704a291a6e3774e053f11d7c827c8a45

Gif/Video: http://gyazo.com/4d031554609edf133a41312f863cb6b5

Hmmmmmm, this is hard! Blush
Reply
19-02-2014, 04:08 PM, (This post was last modified: 19-02-2014, 04:08 PM by EA3GCV.)
#4
RE: TQSL signing problem! (Swisslog)
Hi,

When you press Start Sync to run the LotW automatic mode enter the date of your first QSO (or an earlier date) in the field QSO's since and QSL since to perform a full resync of the whole logbook. This should work but it will take a while depending on your number of QSO's.

73
Jordi, EA3GCV
Current developer of Swisslog
Reply
20-02-2014, 06:07 PM, (This post was last modified: 20-02-2014, 09:22 PM by la1mfa.)
#5
RE: TQSL signing problem! (Swisslog)
(19-02-2014, 04:08 PM)ea3gcv Wrote: Hi,

When you press Start Sync to run the LotW automatic mode enter the date of your first QSO (or an earlier date) in the field QSO's since and QSL since to perform a full resync of the whole logbook. This should work but it will take a while depending on your number of QSO's.

73
Hi,

This is what happens. It only "finds" 96 QSO's.
http://gyazo.com/ca5bd74a1f390b2bf6bd6c2edf227107 The picture only shows the loading..

After the loading is done, it jumps right to "Wait for upload to completion", and it stays there.
Reply
21-02-2014, 03:39 AM,
#6
RE: TQSL signing problem! (Swisslog)
Are you using Windows Vista or upper version? Did you installed Swisslog and Trusted QSL with administrator rights? this is a MUST in these operating systems! (Vista, 7 or 8). How many QTH have created in My QTH in Swisslog? How many stations have created in TQSL? Have you matched each TQSL station with the corresponding My QTH in Swisslog?

Excuse me for so many questions but I need to get more information to find put what's happening...

Best 73
Jordi, EA3GCV
Current developer of Swisslog
Reply
22-02-2014, 12:55 AM, (This post was last modified: 22-02-2014, 12:56 AM by la1mfa.)
#7
RE: TQSL signing problem! (Swisslog)
(21-02-2014, 03:39 AM)ea3gcv Wrote: Are you using Windows Vista or upper version? Did you installed Swisslog and Trusted QSL with administrator rights? this is a MUST in these operating systems! (Vista, 7 or 8). How many QTH have created in My QTH in Swisslog? How many stations have created in TQSL? Have you matched each TQSL station with the corresponding My QTH in Swisslog?

Excuse me for so many questions but I need to get more information to find put what's happening...

Best 73
Feel free to ask all the questions you want Smile

We are running Windows 7. I am not sure if it was installed in administrator mode or not.
Only one QTH is created in Swisslog and I guess the stations are matched with the corresponding QTH in Swisslog..

It is me/Martin the son of LA1MFA that is writing here.

Here he have written me a weird problem that happened.
"I started with LOTW in the beginning of 2014. The first time I tried to upload contacts from Swisslog, it uploaded 2500 qso's of my total of 22000+. It looks likes the qso's Swisslog managed to sync, were spread from the time period (1985-2013). After this all new qso's loaded correct and I managed to get them online on LOTW. Later I found 7 qso's from 2013 that hadn't been uploaded to LOTW. Therfore I tried to log them in to the Swisslog system one more time with the same time/period, and then they got uploaded.
But 3.Feb something happened. No qso's were able to load (old and new ones) for some weird reason..

A lot of information and explanation in one post, but I hope you get some out of it!
Thanks for helping us out.
Reply
24-02-2014, 09:54 AM,
#8
RE: TQSL signing problem! (Swisslog)
Hello again,

It's extremely important that Swisslog is installed with administrator rights in windows Vista, 7 or 8 otherwise the results can be unexpected!

So if you don't remember this, I suggest you to install again from the scratch. First of all make sure that you have made a backup of your Swisslog database. If you didn't installed Swisslog with administrator rights the real database could be located elsewhere! look first for the location of all the SWLOG_V5.MDB files (if you didn't renamed it!) and save all the files. The right one will be the newest one! When Swisslog is properly installed the database location is normally C:\Program files\Swisslog\DB.

After you have made sure that you have a copy of your Swisslog database uninstall it from Add/Quit programs from the control panel. Restart and manually delete all the remaining Swisslog folders and or files. I highyl recommed you to run a cleaner such a CCleaner (it's free: http://www.filehippo.com/es/download_ccleaner) to delete all unused files and registry entries. It's a MUST have program!

Download the full version and the updater from the following links:

- full version: http://www.swisslogforwindows.com/Downlo...og_5.8.exe

- Updater: http://www.spanish.icap.ch/Ficheros/SWLV...13_ENG.exe

Install them in the same order but right clicking over each file and select "RUN WITH ADMINISTRATOR RIGHTS". Make sure that Swisslog is installed in C:\Program files\Swisslog (or C:\Program Files (x86)\Swisslog in 32 bits systems!).

After Swisslog is installed copy your real Swisslog database in C:\Program Files\Swisslog\DB overwriting the existing one. Open Swisslog and check that you have all QSO's. You will have to setup again LotW and other functions such as rotator control, rig control etc.

Once all is working properly perform a new FULL sync with LotW from the first QSO date. But first make sure that the certificate and station is properly installed in TQSL. Otherwise uninstall and install TQSL with administrator rights.

If you follow all these step we ensure that Swisslog has been installed properly. The LotW function works well but Swisslog must be installe with administrator rights. In fact I suggest you to disable UAC in Windows (Google it to know how to do it!) and run all programs with administrator rights to avoid many many problems with most window programs.

I hope these will solve all the problems!

Best 73
Jordi, EA3GCV
Current developer of Swisslog
Reply
24-02-2014, 10:18 PM,
#9
RE: TQSL signing problem! (Swisslog)
Hi mate!

Thank you for your help. I have done alle your steps (step by step), and it cinda worked out..

I synced my Swisslog from this start and end date. http://gyazo.com/29d417554cf05ac0c936e441ee97071e
We also tried from 1889, but it only got 96 Qso's. Those 96 Qso's came from the time period from 03.Feb 2014 to today (24.02.2014).

So the wierd thing here is that is doesen't take all the other 20000+ contacts.. Now we only got those 96 extra on LOTW.

Here comes another wierd thing.. If we add an old contact again in Swisslog, it does take it and upload it. So it looks like Swisslog will take all new Qso's that is added in Swisslog and those old contacts that is re-added.

Do you want to write with us on skype, so we can check out things live? I can also provide you with TeamViewer so you can see our deskop.. And you can also have out database and try?

Thank you for taking time to help me/us!!

- Kjell Berg/LA1MFA - Martin (son).
Reply
26-02-2014, 07:57 PM,
#10
RE: TQSL signing problem! (Swisslog)
Look at this

http://gyazo.com/61c0acb159186e54d4bbca88c4a319df

End date 1899... How can we change this? Can this cause our problem?
Reply


Forum Jump:


Users browsing this thread: 4 Guest(s)